2012年03月30日

Notice: add_contextual_help の使用はバージョン 3.3 から非推奨になっています! 代わりに get_current_screen()->add_help_tab() を使ってください。の直し方が見つからない。

たぶん、
get_current_screen()->add_help_tab()
に直したら出来るんだけど。

直してみてもできなかった。

なので、wordpressの不具合ってことにしておきます。




あるテーマを入れたら、こんなNoticeが出た。
Notice: add_contextual_help の使用はバージョン 3.3 から非推奨になっています! 代わりに get_current_screen()->add_help_tab() を使ってください。


grep検索して、該当ファイルを直してみると
次はこんなエラー
Fatal error: Call to a member function add_help_tab() on a non-object

どうしろっていうんだ。

っていうことで直せませんでした(;´ρ`)


参考までに
add_help_tab() のヘルプ
get_current_screen()->add_help_tab()のヘルプ



にしても、デバックモードをonにしてる人少ないですね。
英語サイトばっかだ。。。
人口の問題かなぁ・・
posted by onishi at 12:52| Comment(0) | wordpress | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント: